$re = '/^((https:\/\/)|(http:\/\/))/mi';
$str = 'http://google.com?query=https
https://www.google.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);