import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " \\r?\\n {24}";
final String string = "RAW DATA \n"
+ "26/11/15 26/11/15 1314 NEFT : CMS364134568 - CRE \n"
+ " DIT CARD OPERATIONS \n"
+ "26/11/15 26/11/15 1314 Cash Deposit \n"
+ "27/11/15 27/11/15 1314 NEFT : CMS364860637 - CRE \n"
+ " DIT CARD OPERATIONS \n"
+ "27/11/15 27/11/15 1314 Cash Deposit \n"
+ "30/11/15 30/11/15 1314 NEFT : CMS365476895 - CRE \n"
+ " DIT CARD OPERATIONS \n"
+ "30/11/15 30/11/15 1314 NEFT : CMS365573866 - CRE \n"
+ " DIT CARD OPERATIONS \n"
+ "30/11/15 30/11/15 1314 NEFT : CMS365623059 - CRE \n"
+ " DIT CARD OPERATIONS";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}