package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)soyad[ıi](.+?)(?:S[ıi]n[ıi]f[ıi]|n(?:o|umara)|[0-9])`)
var str = `2015ÖĞLEYEMEKKARTI(2016-20.AdıMEVLÜTSoyadıERTANĞASınıfıE10/ENo303`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}