package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:Block\[).*(?:\[value])`)
var str = `Block[first_name][value]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}