$re = '/^(?=.*[a-z])(?=.*[A-Z]).{4,}(?=.*\d).{4,}$ /';
$str = 'aAaAaAaA111111aAaAaA';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);