re = /^(.+?):(?:\s+)?([\s\S]+?)\r?\n(?=\r?\n)/
str = 'Billing Address:
Harry Smith
3423 My Lane
SOME CITY, CA 94105
United States
Some more text'
# Print the match result
str.match(re) do |match|
puts match.to_s
end