re = / (?! )|[()\[\]]+ [()\[\]]+(?=\.)|( )/
str = 'H o w T o C r a f t () [.zip
V i d e o G a m e () [.zip'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result