import re
regex = re.compile(r"\d+\?(?:\([\da-z]+\))?", flags=re.MULTILINE)
test_str = "3A 4?(1) 5?(2) 6?(a) 7?(4) 8?(a) 9?(ii) 10?"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")