$re = '/(?![\/-])\D/m';
$str = '123-456/80:abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);