$re = '/([А-Я]{1}[а-я]+)/';
$str = 'Привет, Андрей, ты не Алексей, а ХУЕСОС!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);