import re
regex = re.compile(r"^(.*?)\s*eth.*?\b(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})", flags=re.MULTILINE)
test_str = ("\n\n"
"Wed Mar 18 15:16:10 2015 eth0:1 109.224.232.219 up (not currently mapped)\n"
"Wed Mar 18 15:18:12 2015 eth0:1 109.224.232.219 down (not responding)\n"
"Wed Mar 18 15:20:46 2015 eth0:1 109.224.232.219 up (not currently mapped)\n"
"Wed Mar 18 15:22:52 2015 eth0:1 109.224.232.219 down (not responding)\n"
"Wed Mar 18 15:24:26 2015 eth0:1 109.224.232.219 up (not currently mapped)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")