import re
regex = re.compile(r"(?P<shortcode>(?:(?:\s?\[))(?P<name>[\w\-]{3,})(?:\s(?P<attrs>[\w\d,\s=\"\'\-\+\#\%\!\~\`\&\.\s\:\/\?\|]+))?(?:\])(?:(?P<html>[\w\d\,\!\@\#\$\%\^\&\*\(\\)\s\=\"\'\-\+\&\.\s\:\/\?\|\<\>]+)(?:\[\/[\w\-\_]+\]))?)", flags=re.UNICODE)
test_str = ("<p> </p>\n"
"[caption id=\"attachment_674\" align=\"alignright\" width=\"300\"]<a href=\"/wordpress/wp-content/uploads/2015/05/photo-14-5-15-21-27-17.jpg\"><img class=\"wp-image-674 size-medium\" src=\"/wordpress/wp-content/uploads/2015/05/photo-14-5-15-21-27-17.jpg?w=300\" alt=\" Χαρίδημος Κ. Τσούκας\" width=\"300\" height=\"300\" /></a> Ο Χαρίδημος Κ. Τσούκας[/caption]\n\n"
"<p>Την Πέμπτη 14 Μαϊου 2015, στο βιβλιοπωλείο IANOS έλαβε χώρα μια πολύ ενδιαφέρουσα συζήτηση που διοργανώθηκε με αφορμή την κυκλοφορία του βιβλίου του καθηγητή Χαρίδημου Κ. Τσούκα, <strong>\"Η τραγωδία των κοινών: Πολιτική φαυλότητα, απαξίωση θεσμών και χρεοκοπία\"</strong>. Στην συζήτηση, με θέμα \"Πώς μιλάμε για τα κοινά; Για την ποιότητα του δημόσιου λόγου στην Ελλάδα, σήμερα\", συμμετείχαν οι Απόστολος Δοξιάδης, συγγ\n"
"</ol>\n"
"<ol start=\"3\">\n"
" <li>Η επίπτωση αυτού του πολέμου εναντίον της σκέψης ισοδυναμεί με ψυχικό τραύμα, που οι βαθύτερες επιπτώσεις του στα πρόσωπα, τις συλλογικότητες και τον πολιτισμό εκτείνονται πολύ πέρα από τα όρια της παρούσας κρίσης. (Πρβλ. «Μια κατοχή σας χρειάζεται!»)</li>\n"
"</ol>\n"
"<p>[gallery ids=\"766,760,759,757\"]</p>\n"
"<p> </p>\n"
"<ol start=\"4\">\n"
" <li>Η όλη εμπειρία της κρίσης ισοδυναμεί με ψυχική κακοποίηση των ανθρώπων.</li>\n"
"</ol>\n"
"[caption id=\"attachment_680\" align=\"aligncenter\" width=\"300\"]<a href=\"/wordpress/wp-content/uploads/2015/05/photo-14-5-15-21-45-05.jpg\"><img class=\"size-medium wp-image-680\" src=\"/wordpress/wp-content/uploads/2015/05/photo-14-5-15-21-45-05.jpg?w=300\" alt=\"Από αριστερά: Ηλίας Κανέλλης, Νίκος Σιδέρης, Απόστολος Δοξιάδης, Χαρίδημος Κ. Τσούκας.\" width=\"300\" height=\"300\" /></a> Από αριστερά: Ηλίας Κανέλλης, Νίκος Σιδέρης, Απόστολος Δοξιάδης, Χαρίδημος Κ. Τσούκας.[/caption]\n"
"<p>ΙΙΙ. ΑΝΑΒΑΘΜΟΙ ΤΟΥ ΦΑΙΝΟΜΕΝΟΥ </p>\n"
"<ol>\n"
" <li>Η αρχή «Τρέλαινε, διαίρει και βασίλευε» αναγορεύεται σε δεσπόζουσα μεθοδολογία διακυβέρνησης.</li>\n"
"</ol>\n"
"<ol start=\"2\">\n"
" <li>Το κατά Διαβόλου ευαγγέλιο, που συμπυκνώνεται στην εντολή «Μισείτε αλλήλους», προωθείται ως (τερατώδες) υπόδειγμα «κοινωνικής συμβίωσης χωρίς κοινωνικό δεσμό». <em>(Βλέπε ευχή «Να πάθει ο άλλος ό,τι έχω πάθει εγώ».)</em></li>\n"
"</ol>\n"
"<ol start=\"3\">\n"
" <li>Αυτός ο λόγος τροφοδοτεί τη χείριστη πτυχή της νεοελληνικής συλλογικής και προσωπικής νοοτροπίας και ψυχολογίας – τουτέστιν, τη φαντασίωση «Ο άλλος τρώει» και τα φοβερά παράγωγά της: Φθόνος, ανταγωνισμός, επιθετικότητα, δυσπιστία… Καλλιεργώντας ως οδηγό επιβίωσης τη λογική «Σώσε το τομάρι σου, καθένας για πάρτη του, όλοι εναντίον καθενός, όλοι εναντίον όλων, φά’ τους να μη σε φάνε»: Homo homini lupus ̶ καθολικός λυκανθρωπισμός. Αυτή η λογική εκλύει τρομακτικές διεργασίες καταστροφικότητας που πλήττουν τον κοινωνικό δεσμό, την ανθρώπινη σχέση και την υποκειμενική ευστάθεια των ανθρώπων («κοινωνικός αυτοματισμός», καθολική δυσπιστία, απουσία κοινού λόγου, υποκειμενική κακουχία).</li>\n"
"</ol>\n"
"<ol start=\"4\">\n"
" <li>Ενορμητική θεμελίωση αυτών των διεργασιών: Το κατά Διαβόλου ευαγγέλιο προωθεί την κατάλυση των δεσμών, τόσο στο διαπροσωπικό και το συλλογικό όσο και στο ενδοψυχικό επίπεδο. Και, υπ’ αυτή την έννοια, ψυχαναλυτικά μιλώντας, ισοδυναμεί με Θρίαμβο του Θανάτου ̶ της Ορμής του Θανάτου.</li>\n"
"</ol>\n"
"<p> IV.Ο ΠΟΛΕΜΟΣ ΤΗΣ ΣΚΕΨΗΣ Τι σημαίνει «Τρέλαινε, διαίρει και βασίλευε»: Τρέλαινε = πρόκληση διανοητικής εμπλοκής μέσω του επικοινωνιακού περιβάλλοντος του «διπλού δεσμού» = τα μυαλά των ανθρώπων βομβαρδίζονται με παράδοξα, αντιφατικά μηνύματα που αλληλοακυρώνονται, ενώ ταυτόχρονα απαγορεύεται να σκεφτείς και να σχολιάσεις το συγκεκριμένο παράδοξο. Συγκεκριμένα, στην Ελλάδα της κρίσης: Αν αντισταθείς, χάθηκες (δραχμή, χρεωκοπία κτό). Αν υποκύψεις, χάθηκες (ανεργία, φτώχεια, κλείσιμο μαγαζιών, ταπείνωση…). Και απαγορεύεται να σκεφτείς επειδή «είναι μονόδρομος». Η παθογόνος επίπτωση της επικοινωνιακής μηχανής «διπλός δεσμός» ενισχύεται από το ότι μια σειρά ιστορικές διεργασίες έχουν διαμορφώσει ένα ψυχοδιανοητικό κενό. Οι διεργασίες αυτές είναι οι ακόλουθες: -Η διάλυση του νοήματος των λέξεων (βλ. \"Οι βάσεις φεύγουν για πάντα\" που στην πράξη σημαίνει \"Οι βάσεις μένουν για πάντα και κανείς δεν θα μιλήσει πια γι' αυτό\" ̶ όπερ και εγένετο) -Η κοινωνική διαίρεση, απωθημένη στους καιρούς της Μεγάλης Αυταπάτης, που τώρα επιστρέφει τραυματικά – σαν κάτι που δεν το χωράει ο νους. -Το σύστημα των συνενοχών, ο γενικευμένος φατριασμός και ο διάχυτος εκμαυλισμός των πολλών-πελατών από την κομματοκρατία, που οδηγεί σε διάλυση του νοήματος των λέξεων και των πραγμάτων και σε εθισμό στην πλασματικότητα, την υποκρισία και την αυταπάτη. -Ο καταναλωτικός ναρκισσισμός, που οδηγεί σε αλλοτρίωση, αλλοίωση του νοήματος των πραγμάτων μέσω του κατά λάιφ-στάιλ φαίνεσθαι, έκπτωση της αναφοράς στην πραγματικότητα και απώλεια των εργαλείων πολιτικού λογισμού. -Η αποκοπή από την παραγωγική εργασία, που οδηγεί στην αδιαφορία ως προς την πραγματικότητα και σε νοοτροπίες «μαϊμού». -Το ιδεολόγημα «διαχείριση αντί πολιτικής», που παραμερίζει το ανθρώπινο στοιχείο και περιορίζεται σε ποσοτικά δεδομένα και ζητούμενα. -Η απαξίωση του καθεστωτικού πολιτικού προσωπικού και της διοίκησης, που συνοδεύει το ότι οι φύλακες του νόμου καλούσαν τους πολλούς σε άνομη απόλαυση. -Η άρνηση του νου να δει ότι η κρίση είναι θέμα Πολιτικής Οικονομίας, δηλαδή διαμάχης για την ισχύ και την επικράτηση. Που έχει μετατρέψει την Ευρώπη σε πεδίο οικονομικού πολέμου και, ειδικότερα, την Ελλάδα σε ιστορικό πείραμα καθυπόταξης των πολιτών με τα εργαλεία του ψυχολογικού πολέμου. Αυτή η άρνηση επίγνωσης έχει βαριές συνέπειες ως προς την κατανόηση της αναγκαιότητας υπεράσπισης του Ευρωπαϊκού οράματος και σχεδίου. -Τέλος, ο εγωκεντρισμός, που οδηγεί σε απόσπαση του Εγώ από το Εμείς και την απώλεια της πλαισίωσης της προσωπικής ύπαρξης από καίριους πολιτισμικούς ρυθμιστές, όπως η κουλτούρα τιμής/ ντροπής. Έτσι προκύπτει ένα μοιραίο ψυχοδιανοητικό κενό ̶ κενό του νου και της ψυχής. Δηλαδή, έλλειμμα ως προς την αναπαράσταση της κατάστασης πραγμάτων· ανεπάρκεια ως προς τις γλώσσες και τους κώδικες επεξεργασίας της εν λόγω ελλειμματικής αναπαράστασης· και ασθενής ψυχοσυναισθηματική επένδυση τόσο του λόγου όσο και της αίσθησης ότι η υποκειμενικότητα μπορεί να καθορίσει το κοινωνικό πλαίσιο της ύπαρξής της. Η στρατηγική του «τρέλαινε» οδηγεί στη χαρακτηριστική στάση που «ανεξήγητα» δεσπόζει και στην 1η περίοδο = πένθιμο μούδιασμα. Δηλαδή, ακόμη και οι βαριά πληττόμενοι από την κρίση αδυνατούν να αντιτάξουν συντεταγμένη αντίσταση και περιμένουν παθητικά «να δουν τι θα γίνει στο τέλος» βυθισμένοι σε απόγνωση. Γι’ αυτό και ο κύριος ψυχολογικός μηχανισμός της κρίσης, όπου συγκλίνουν και αλληλεπιδρούν ιστορικοί, οικονομικοί, κοινωνικοί, πολιτικοί, ιδεολογικοί, πολιτισμικές και ψυχολογικές διεργασίες μπορεί να οριστεί ως Πόλεμος της Σκέψης, με διακύβευμά του το τι κοινωνία και τι ανθρώπους θέλουμε: Υποτακτικούς και αλληλομισούμενους νεο-ραγιάδες ή πολιτισμένους πολιτικούς ανθρώπους που λειτουργούν τη Δημοκρατία. Το «τρέλαινε» συνοδεύεται από την τακτική του «Διαίρει και βασίλευε» = καθένας να σώσει το τομάρι του , καθένας για πάρτη του, όλοι εναντίον καθενός, όλοι εναντίον όλων, φά’ τους να μη σε φάνε (ο διαβόητος «κοινωνικός αυτοματισμός»). Η καλλιέργεια της στάσης «Ο άνθρωπος για τον άνθρωπο λύκος» επιφέρει κακοποίηση των ψυχών και ισοδυναμεί με ψυχικό τραύμα που οι επιπτώσεις του θα έχουν μέλλον. Ωστόσο, ήδη ενεργοποιεί όλες τις αρνητικότητες και προωθεί ως (τερατώδες) πρότυπο κοινωνικής συμβίωσης το κατά Διαβόλου ευαγγέλιο. Που ο πυρήνας του συνοψίζεται στην εντολή «Μισείτε αλλήλους», με παράγωγό της την εντολή «Μίσει τον πλησίον σου ως σεαυτόν» (καλλιέργεια της ενοχοποίησης και της αυτοϋποτίμησης). Και οι (απτές) συνέπειές του συμπεριλαμβάνουν την αποσάθρωση του κοινωνικού δεσμού και την υπονόμευση της ανθρώπινης σχέσης, ακόμη και σε μία κοινωνία αλληλεγγύης με κουλτούρα ανθρώπινης εγγύτητας, όπως η Ελλάδα. Συμπτώματα (μεταξύ άλλων): «Κοινωνικός αυτοματισμός» και ΧΑ (\"Μη σκέφτεσαι, βάρα\") που τρέφονται από την κοινοτοπία της έχθρας και της απόλαυσης του κακού. Στο έσχατο βάθος αυτών των ψυχικών μετασχηματισμών σε προσωπικό, διαπροσωπικό και συλλογικό επίπεδο βρίσκεται μία αναδιάταξη των ψυχικών διεργασιών, που φέρνει στο πηδάλιο της ψυχικής ζωής την Ορμή του Θανάτου, που ορίζεται ως αποσύνθεση και λύση των δεσμών και των ενοτήτων. Ως εκ τούτου, στο μέτρο που εμπεδώνεται το κατά Διαβόλου ευαγγέλιο, αναφύονται καταστάσεις που ισοδυναμούν με Θρίαμβο του Θανάτου (Ο θάνατός σου η ζωή μου). Και απολήγουν σε αποσταθεροποιημένη υποκειμενικότητα, όπου δεσπόζει η αίσθηση αποξένωσης από τις διεργασίες διαμόρφωσης του συλλογικού πεπρωμένου, άρα και του κοινωνικού πλαισίου κάθε προσωπικής ύπαρξης [λόγω έκπτωσης του Συμβολικού, «διαρροής» του Φαντασιακού, αχαλίνωτης επίπτωσης του Πραγματικού και εμπλοκής της Ποιητικής λειτουργίας]. <a href=\"http://www./wordpress/publication-details.asp?book=618&filter=new\"><img class=\"aligncenter wp-image-675 size-medium\" style=\"border: 1px solid #000000;\" src=\"/wordpress/wp-content/uploads/2015/05/9789605720544-2.jpg?w=207\" alt=\"Η τραγωδία των κοινών\" width=\"207\" height=\"300\" /></a></p>\n"
"<ol>\n"
" <li>V. ΚΥΒΕΡΝΗΤΙΚΗ ΚΑΙ ΠΟΛΙΤΙΚΗ ΜΕΤΑΒΟΛΗ (25-01-15)</li>\n"
"</ol>\n"
"<p> <strong>1<sup>η</sup> περίοδος: Πριν την 20-02-15</strong></p>\n"
"<ul>\n"
" <li>Κύριο γνώρισμα [recent-posts]του νέου κυβερνητικού λόγου είναι η αποδόμηση του διπλού δεσμού («Δεν είναι μονόδρομος») και της απόγνωσης <em>(τα άλλα 3 αρνητικά συναισθήματα ± παραμένουν, δεόντως μετασχηματισμένα: άλογος και έλλογος φόβος, ανήμπορη οργή, αγωνιώδης αναμονή)</em>. Μηχανισμός της μεταβολής: Το «τρέλαινε-διαίρει-βασίλευε» αντικαθίσταται από λόγο που αντιστοιχεί σε «Εμψυχώνω-Συσπειρώνω-Μάχομαι» («Άλλοι, άλλο, αλλιώς»)</li>\n"
"</ul>\n\n"
"[linkbutton]Click Me![/linkbutton]\n"
"<ul>\n"
" <li>Ωστόσο, ο Πόλεμος της Σκέψης \n"
"συνεχίζεται: Και από το «Μνημονιακό στρατόπεδο» εντός κι εκτός Ελλάδας, και μέσα από τις αντιφάσεις του νέου Κυβερνητικού λόγου</li>\n"
"</ul>\n"
"<p><strong>2η περίοδος: Μετά την 20-02-15</strong> Η αποδόμηση του διπλού δεσμού και της απόγνωσης του \"Είναι μονόδρομος\" αποδέσμευσε τη σκέψη και έφερε μια σύντομη άνοιξη τριών εβδομάδων, όπου ο νους και η ψυχή πήραν ανάσα. Ωστ[chart type=\"pie\" title=\"Example Pie Chart\" data=\"41.12,32.35,21.52,5.01\" labels=\"First+Label|Second+Label|Third+Label|Fourth+Label\" background_color=\"FFFFFF\" colors=\"D73030,329E4A,415FB4,DFD32F\" size=\"450x180\"]όσο, ο Πόλεμος της σκέψης (και όχι μόνο) συνεχιζόταν (και συνεχίζεται). Η ελαφρότητα των χειρισμών (\"Πέσαμε θύματα παραπλάνησης\" κ[menu name=\"main-menu\"]τό) και η σκληρότητα του αντιπάλου συνοδεύονταν από την καλλιέργεια της αυταπάτης για λύση μέσω ευφημισμών σε περιβάλλον \"δημιουργικής ασάφειας\". Η οποία παραβλέπει το ότι στην πολιτική ο έσχατος ερμηνευτής κάθε ασάφειας και κριτής κάθε διαφοράς είναι ο συσχετισμό[googlemap width=\"600\" height=\"300\" src=\"http://maps.google.com/maps?q=Heraklion,+Greece&hl=en&ll=35.327451,25.140495&spn=0.233326,0.445976& sll=37.0625,-95.677068&sspn=57.161276,114.169922& oq=Heraklion&hnear=Heraklion,+Greece&t=h&z=12\"]ς των δυνάμεων. Αποτέλεσμα, η βίαιη αναμόρφωση του κυβερνητικού λόγου συνηχεί με την προπαγανδιστική καταιγίδα των αντιπάλων της. Συνέπεια: Η ακριβολογία<a href=\"#_ftn1\" name=\"_ftnref1\">[1]</a> τίθεται εκ[pdf width=\"520px\" height=\"700px\"]http://static.fsf.org/common/what-is-fs-new.pdf[/pdf] νέου εκποδών και η ακυρολογία κυριαρχεί. Και το οικείο περιβάλλον του προ της κυβερνητικής μεταβολής κυρίαρχου δημόσιου λόγου επανέρχεται, με οδηγά στοιχεία του το νεκραναστημένο \"Είναι μονόδρομος\", την ανημπόρια κατονομασίας των πραγμάτων με το πραγματικό τους όνομα και ένα ανάλογο πένθιμο μούδιασμα. Η σύντομη άνοιξη του λόγου και της ψυχής ήδη αποκτά μια πρόγευση τέλους εποχής. </p>\n"
"<ol>\n"
" <li>VI. ΤΟ ΚΥΡΙΟ ΠΟΡΙΣΜΑ</li>\n"
"</ol>\n"
"<p> Όσο οι λέξεις δεν αποδίδουν τα πράγματα και δεν αξιοποιούνται πρόσφορα διανοητικά εργαλεία για συγκεκριμένη ανάλυση της συγκεκριμένης κατάστασης (π.χ. έννοιες όπως διπλός δεσμός, γκραμσιανή ηγεμονία, Πόλεμος της Σκέψης, Στρατηγική Ηγετική λειτουργία –βλ. Τσούκας), το δύσκολο γίνεται ακόμη πιο δύσκολο και, στην πορεία, ακατανόητο-αδιανόητο-τραυματικό. Με άλλα λόγια: Όσο περισσότερο κάτι χάνεται στον πόλεμο των λέξεων, άρα και της σκέψης, τόσο πιο δύσκολα κατακτάται ή ανακτάται σε άλλα πεδία. Όθεν συνάγεται ότι αυτό που κυρίως απαιτούν οι καιροί είναι να σκεφτούμε, να σκεφτούμε, να σκεφτούμε, και προπαντός να σκεφτούμε! VIΙ. ΥΠΑΡΧΕΙ ΑΝΤΙΔΟΤΟ; </p>\n"
"<ul>\n"
" <li>Η επίπτωση αυτού του πολέμου εναντίον της σκέψης ισοδυναμεί με ψυχικό τραύμα, που οι βαθύτερες επιπτώσεις του στα πρόσωπα, τις συλλογικότητες και τον πολιτισμό εκτείνονται πολύ πέρα από τα όρια της παρούσας κρίσης. (Πρβλ. «Μια κατοχή σας χρειάζεται!»)</li>\n"
"</ol>\n"
"<p>[gallery ids=\"766,760,759,757\"]</p>\n"
"<p> </p>\n"
"<ol start=\"4\">\n\n"
" <li>Το βασικό αντίδοτο γι’ αυτή την κακοποίηση των ψυχών δεν είναι η πρόσθετη κακοποίηση και απαξίωση. Είναι να σκεφτούμε, να σκεφτούμε, μα σκεφτούμε – και, προπαντός, να σκεφτούμε. Πιο συγκεκριμένα, το εν λόγω αντίδοτο σ’ αυτή την αρνητικότητα είναι μια διανοητική και ηθική μεταρρύθμιση, που έχει δύο πυλώνες: Μια Θεραπεία αλήθειας (απαλλαγή από τις μεγάλες αυταπάτες) και Επιστροφή στους ανθρώπους (αντί του καταναλωτικού ναρκισσισμού και της επικράτησης των ποσοτικών λογικών). Και υλοποιείται ως υπεράσπιση της ζωής έναντι του Θανάτου. Ως καλλιέργεια του κοινωνικού δεσμού και ποικίλων «εμείς», που θα αναλάβουν την ιστορική πρωτοβουλία αποκρούοντας το Μισείτε αλλήλους. Ως υπεράσπιση της σκέψης και του έγκυρου λόγου. Ως δημοκρατική λειτουργία πολιτισμένων πολιτικών ανθρώπων, αντί της λυκανθρωπικής αλληλοφαγίας, της αυταρχικότητας και της υποταγής. Που στην ουσία σημαίνει ότι υπερασπίζουμε με πάθος έναν Δημοκρατικό Ανθρωπισμό – εγγύηση για το ύψιστο αγαθό, που είναι η αξιοπρέπεια.</li>\n"
"</ul>\n"
"<ul>\n"
" <li>Η Ιστορία το συνηθίζει να αξιοποιεί στο έπακρο τις πανουργίες του Λόγου. Στο χέρι μας είναι, η σημερινή αντιξοοότητα και ιδιαίτερα ο Πόλεμος της Σκέψης, που μαίνεται και γύρω αλλά και μέσα στον καθένα μας, να ενεργοποιήσει εκείνες τις διεργασίες, που θα μετουσιώσουν την εμπειρία του κακού σε εφαλτήριο αναβάθμισης της προσωπικής και της συλλογικής μας ύπαρξης.</li>\n"
"</ul>\n"
"<p> <em>Ο Νίκος Σιδέρης είναι ψυχίατρος, ψυχαναλυτής και συγγραφέας. Στο βιβλίο του \"Το κατά Διαβόλου ευαγγέλιο - Πολιτική Ψυχολογία της Κρίσης\" (Μεταίχμιο 2014) αναλύει εκτενώς τους ψυχολογικούς μηχανισμούς της κρίσης.</em> <a href=\"#_ftnref1\" name=\"_ftn1\">[1]</a> <em>Ενδογενής τελεστικότητα πολιτικού λόγου: Δεν περιγράφει ούτε αποδεικνύει ̶ επιτελεί </em> </p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")