# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:(?![JjSs][rR]\.|\b(?:[IV]+))[^,]+))"
test_str = ("O'Kefe,Shiley\n"
"Folenza,Mitchel V\n"
"Briscoe Jr.,Sanford Ray\n"
"Andade-Alarenga,Blnca \n"
"De La Cru,Feando\n"
"Carone,Letca Jo\n"
"O'Conor,Mole K\n"
"Daeron III,Lawence P\n"
"Randall,Jason L\n"
"Esquel Mendez,Mara D\n"
"Dinle III,Jams E\n"
"Coras Sr.,Cleybr E\n"
"Hsieh-Krnk,Caolyn E\n"
"Graves II,Theodore R\n"
"absdsjad\n"
"salkdjskd,sjsj\n"
"skjd")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.