$re = '/^(.*)(\S*\s*){2}$/';
$str = 'My words I want to match';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);