$re = '/^(?:(?!John).)*(?=\s)/m';
$str = 'I am John, you are John also
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);