$re = '/((\d{1,3}\D+){3}\d{1,3})/';
$str = '131 211 32 43';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);