package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(a-zA-Z)*`)
var str = `
bhklkokl
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}