package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^EAN]*$)*\d{3}\d{4,6}\d{3,5}\d`)
var str = `EAN\n\n0889842596601\n\nUtilização\n\nMobilidade\n\nProcessador\n\nIntel® Core™ m3-8100Y Dual Core\n\nFrequência\n\n1,1 GHz\n\nCache Processador\n\n4 MB\n\nMemória RAM\n\n8 GB\n\nTipo Memória\n\nLPDDR3\n\nPlaca(s) Gráfica(s)\n\nIntel HD Graphics\n\nDisco SSD\n\n128 GB\n\nDimensão Ecrã\n\n10,51 ''\n\nTipo de Ecrã\n\nEcrã tátil PixelSense com resolução 1920 x 1280\n\nSistema Áudio\n\nAltifalantes estéreo 2W\n\nLeitor de Cartões\n\nLeitor de cartões microSD\n\nInterfaces\n\n1x USB-CSurface Connect™Jack 3,5mm\n\nCâmara\n\nCâmara frontal de 5 MP com 1080pCâmara posterior de 8 MP com 1080p\n\nComunicações\n\nWi-Fi 6 802.11axBluetooth 5.0LTE com suporte nanoSIM e eSIM\n\nSistema Operativo\n\nWindows 10 Home em modo S (64-bit)\n\nBateria\n\nLi-ion\n\nAutonomia (estimativa)\n\nAté 9,5 horas\n\nOutras Funcionalidades\n\nAcelerômetroMagnetômetroGiroscópioSensor de luz ambiente\n\nDimensões\n\n24,5 x 17,5 x 0,83 cm\n\nPeso\n\n0,54 Kg\n\nAcessórios\n\nFonte de alimentação\n\nOutros\n\nCapa teclado vendida separadamente\n\nMenção Legal\n\nTenha em atenção o país de expedição do vendedor, pois o `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}