$re = '/^[A-Z]{5}\d{4}[A-Z]$/';
$str = 'ABCDC1234D';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);