$re = '/(\d)\1+\b(*SKIP)(*FAIL)|\d+/';
$str = '00000000 111111111 12345678 123 00 12 55 1 2 3 88888';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);