package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.testnet$`)
var str = `example.testnet
sub.ex.testnet
something.testnet
shouldnotendwithperiod.testnet.
space should fail.testnet
touchingDotsShouldfail..testnet
example.near`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}