$re = '/^\d*\.?\d+:\d*\.?\d+$/m';
$str = '0.4:0.9
.4:.9
4:9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);