$re = '/(\d{3})@.*?@(\d{3})-(\d{3})-(\d{4})\s+(\d{2}:\d{2}:\d{2})\s(\d{8})@(.*?)@(.{15})(.*?)([BRPC].{3})@(.*?)@(.*?)LEC\s(.*?)@(.{29})([A-Z]{2})@.*?@.*?ESN(.*?)@P#(\d{3})-(\d{3})-(\d{4}).*?@.*?@.*?@(.*?)@(.*?)@(.*?)@/';
$str = '_203@ @815-288-3323 14:11:24 01162018@DIXON COUNTY FIRE DEPARTMENT @210 S BUSN@HENNEPIN @ AVE LEC CTL @DIXON IL@ @ ESN 191@P#815-288-3323 ALT# - - @X Y CF @UNC Z ZUNC @DIXON POLICE @DIXON CITY FIRE @DIXON CITY AMBULANCE @_
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);