$re = '/shop\/.*?(?P<last>[^\/]+)$/m';
$str = '/shop/category1/category2/category3
/shop/category1/category2/category3/category4/category5
/shop/category1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);