$re = '/<div[^>]*id="post-contents"[^>]*>(.*?)<\/div>/m';
$str = '<div id="post-contents"><p dir="ltr">HI HI HI</p></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);