using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\d+\K\s+(?=[a-z])";
string input = @"Glenn: $53 Sutter: $44.21
Glenn: $53 Sutter: $44 x
Glenn: 53 Sutter: $44 x";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}