package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)(?:=([^\s;][^;\n]*))?`)
var str = `Name=Value; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly
Name=Another_Value; expires=Wed, 02 Jan 2019 00:00:00 GMT; domain=.another_site.com; path=/newpath; httponly`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}