using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(iso\s+[-\d]+:)(.+:)?(\d{4}(?:\(e\))?)";
string substitution = @"$1$3";
string input = @"ISO 11784:1996/Amd.2:2010(E)
ISO 11784:2010(E)
ISO 11784:2010
ISO 11784-2-3-4:1996/Amd.2:2010(E)
ISO 11784-2-8-7:2010(E)
ISO 11784-5-120-78949-56-789:2010
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}