# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:bs )?(?:en )?(?:np )?(?:is[o0]|DIN)\s+[-\d]+:)(.+:)?(\d{4}(?:\(\w\))?)"
test_str = ("ISO 11784:1996/Amd.2:2010(E)\n"
"ISO 11784:2010(E)\n"
"ISO 11784:2010\n"
"ISO 11784-2-3-4:1996/Amd.2:2010(E)\n"
"ISO 11784-2-8-7:2010(E)\n"
"ISO 11784-5-120-78949-56-789:2010\n"
"BS EN ISO 11784:1996/Amd.2:2010(E)\n"
"EN ISO 11784:2010(E)\n"
"IS0 11784:2010\n"
"EN NP IS0 11784-2-3-4:1996/Amd.2:2010(E)\n"
"BS IS0 11784-2-8-7:2010(E)\n"
"EN NP ISO 11784-5-120-78949-56-789:2010\n"
"EN DIN 11784-5:2019(B)")
subst = "$1$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.