package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[\wà-ãè-êò-õì-ïù-üñç]`)
var str = `AaAãâeèÉÁsdasdíìiîúùñÑ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}