$re = '/^[12]\d{3}$/m';
$str = '2018
2019
2020
test1
test2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);