$re = '~(?<=/|^)\w[\w-]{3,}~m';
$str = '100/ABC-12345 10
ABCD
ZZZ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);