$re = '/(.*\n?.*\.)\s?(?:\(Reminder (\d*)\))*/m';
$str = 'L-I-F-Dolor sit amet. Lorem Ipsum. (Reminder 2)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);