const regex = /\S*_((?!en)\S{2,3}(-\S{2,3})?)\.properties/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S*_((?!en)\\S{2,3}(-\\S{2,3})?)\\.properties', 'g')
const str = `# Don't match default language files
labels_en.properties
labels_en-EN.properties
# Match other languages files
labels_fr.properties
labels_fr-FR.properties
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}