re = /^
(?<date>\d{2}\/\d{2})
(?:\s+(?<description>.*?))??
(?:
\s+
(?:(?<value_sign>[-+])\s)?
(?<value>\d{1,3}(?:\.\d{3})*(?:,\d+)?)
)
\n
(?<categories>.*)/mx
str = '16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 45,97
SAÚDE .RECIFE
12/12 - 23
No description, negative value
12/12 23
No description, unsigned value
12/12 + 23
No description, positive value
12/12 A description that contains a - hyphen - 14
with negative number
12/12 A description that contains a + plus + 14
with positive number
12/12 Adjacent hyphens - - 1
with negative number
12/12 Adjacent pluses + + 1
with positive number
12/12 Adjacent hyphens -- 1
with no space
12/12 Adjacent pluses++ 1
with no space
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end