re = /(["\'])(?:\\.|[^\\\1])*?\1/m
str = '\'abc\'
"abc"
"abc\'s"
"ab\\""
s = \'abc\' + \'def\'
\'This is missing a closing \\\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end