# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0|84)(2(0[3-9]|1[0-689]|2[0-25-9]|3[2-9]|4[0-9]|5[124-9]|6[0369]|7[0-7]|8[0-9]|9[012346789])|3[2-9]|5[25689]|7[06-9]|8[0-9]|9[012346789])([0-9]{7})$"
test_str = ("0917123123\n"
"0901123123\n"
"0931123123\n"
"0891123123\n"
"0701123123\n"
"0761123123\n"
"0771123123\n"
"0781123123\n"
"0791123123\n"
"01201123123\n"
"01211123123\n"
"01221123123\n"
"01261123123\n"
"01281123123\n"
"0911123123\n"
"0941123123\n"
"0881123123\n"
"0811123123\n"
"0821123123\n"
"0831123123\n"
"0841123123\n"
"0851123123\n"
"01231123123\n"
"01241123123\n"
"01251123123\n"
"01271123123\n"
"01291123123\n"
"0961123123\n"
"0971123123\n"
"0981123123\n"
"0861123123\n"
"0321123123\n"
"0331123123\n"
"0341123123\n"
"0351123123\n"
"0361123123\n"
"0371123123\n"
"0381123123\n"
"0391123123\n"
"01621123123\n"
"01631123123\n"
"01641123123\n"
"01651123123\n"
"01661123123\n"
"01671123123\n"
"01681123123\n"
"01691123123\n"
"0921123123\n"
"0561123123\n"
"0581123123\n"
"0521123123\n"
"01881123123\n"
"01861123123\n"
"0991123123\n"
"0591123123\n"
"01991123123\n"
"0871123123\n"
"0551123123")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.