re = /^\"(\(*)(\(\))*(\)*)\"$/m
str = '"()()()"
"((((()))))"
"(()((()))())"
"())()"
"(((((())))))"
"(x)"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end