re = /(mystring\/([0-9]{10}))/m
str = 'hello mystring/1234567890 hello world mystring/2345678901 hellomystring/1234567890 hello world mystring/2345678901 hello'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end