import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<body>(.*?)<\\/body>";
final String string = "\n"
+ "<!doctype html>\n"
+ "<head>\n"
+ " <meta charset=\"utf-8\">\n"
+ " <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0\">\n"
+ " <meta name=\"description\" content=\"\">\n"
+ " <meta name=\"author\" content=\"\">\n\n"
+ " <link href=\"http://localhost//themes/default/../dashboard/css/bootstrap.min.css\" rel=\"stylesheet\" type=\"text/css\" />\n\n"
+ " <link rel=\"stylesheet\" type=\"text/css\" href=\"http://localhost//assets/cache/default_product_groups_product_groups_mod.css\" media=\"screen\" />\n"
+ " <link rel=\"shortcut icon\" href=\"http://localhost//favicon.ico\">\n"
+ "</head>\n\n"
+ "<body>\n"
+ " <p dir='rtl'>\n"
+ " <a target='_blank' href='https://zuz.mx/2e5y'>לרכישה מכאן במחיר 37.01$</a>\n"
+ " </p>\n\n"
+ " <input id=\"base_url_special\" type=\"hidden\" name=\"base_url_special\" value=\"http://localhost//\"/>\n\n"
+ "</body>\n"
+ "<script src=\"http://localhost//themes/default/js/jquery.min.js\" type=\"text/javascript\"></script>\n\n"
+ "<script src=\"http://localhost//assets/cache/default_fetchPG_product_groups_mod.js?_dt=1492617362\" type=\"text/javascript\"></script>\n"
+ "<script src=\"http://localhost//themes/default/../dashboard/js/bootstrap.min.js\" type=\"text/javascript\"></script>\n\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}