$re = '/<body>(.*?)<\/body>/mis';
$str = '
<!doctype html>
<head>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="description" content="">
<meta name="author" content="">
<link href="http://localhost//themes/default/../dashboard/css/bootstrap.min.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="http://localhost//assets/cache/default_product_groups_product_groups_mod.css" media="screen" />
<link rel="shortcut icon" href="http://localhost//favicon.ico">
</head>
<body>
<p dir=\'rtl\'>
<a target=\'_blank\' href=\'https://zuz.mx/2e5y\'>לרכישה מכאן במחיר 37.01$</a>
</p>
<input id="base_url_special" type="hidden" name="base_url_special" value="http://localhost//"/>
</body>
<script src="http://localhost//themes/default/js/jquery.min.js" type="text/javascript"></script>
<script src="http://localhost//assets/cache/default_fetchPG_product_groups_mod.js?_dt=1492617362" type="text/javascript"></script>
<script src="http://localhost//themes/default/../dashboard/js/bootstrap.min.js" type="text/javascript"></script>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);