const regex = new RegExp('\\b\\d+(?:\\|(?!\\d+(?:$|\\|))[^|\\r\\n]+)*', 'gm')
const str = `123|abc|123abc
123|ab12c|abc|456|abc|def
123|1abc|1abc1|456|abc|wer
123|abc|def|456|ghi|jkl|789|mno|pqr`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}