using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\d{2})(?:0(?=(?:\1)1)|1(?=(?:\1)2)|2(?=(?:\1)3)|3(?=(?:\1)4)|4(?=(?:\1)5)|5(?=(?:\1)6)|6(?=(?:\1)7)|7(?=(?:\1)8)|8(?=(?:\1)9))|(\d)(?:09(?=(?:\2)10)|19(?=(?:\2)20)|29(?=(?:\2)30)|39(?=(?:\2)40)|49(?=(?:\2)50)|59(?=(?:\2)60)|69(?=(?:\2)70)|79(?=(?:\2)80)|89(?=(?:\2)90))|099(?=100)|199(?=200)|299(?=300)|399(?=400)|499(?=500)|599(?=600)|699(?=700)|799(?=800)|899(?=900)){4,}\d{3}";
string input = @"531131231331431587
zzz005006007008009010011012zzz
551651751851952052152287
571771871972087
582682882983083183283487
593393593693793893994094194387
564965065165265365487
575775875976076187
526826927027127227487
547747847948048187
518919019119219387
583183283383483583783984084184284387
zzz097098099100101102zzz
zzz198199200201202zzz
zzz297298299300301302zzz
zzz396397398399400401zzz
zzz497498499500501zzz
zzz598599600601602603zzz
zzz697698699700701zzz
zzz796797798799800801zzz
zzz898899900901902903zzz
zzz200201202203204zzz
zzz295296297298299zzz
zzz296297298299300zzz
500000100200300487
599599699799899987
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}