import re
regex = re.compile(r"<tr>(.*?)<\/tr>", flags=re.MULTILINE | re.DOTALL)
test_str = ("<tr>\n"
"<td>84.17.51.209</td>\n"
"<td>3128</td>\n"
"<td>Transparent</td>\n"
"<td>United Kingdom</td>\n"
"</tr>\n"
"<tr>\n"
"<td>84.17.51.209</td>\n"
"<td>3128</td>\n"
"<td>Transparent</td>\n"
"<td>United Kingdom</td>\n"
"</tr>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")