$re = '/<div[^>]*>((?:(?R)|(?:(?!<\/?div)[\s\S]))*)<\/div>/m';
$str = '<div class="1">
abc
<div>div interna</div>
xyz
</div>
<div class="1" >
abc
<p>div2</p>
xyz
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);