re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[$@$!%*?&])[A-Za-z\d$@$!%*?&]{8,}/
str = 'pa$$wordI2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end