package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<months>December)|^(next)\s(?&months)`)
var str = `next December
December 2020 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}