import re
regex = re.compile(r"datafile[0-9]*.txt")
test_str = ("datafile2.txt\n"
"datafile.txt\n"
"datafile1_6.txt\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")