#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z\d]{6}(?:[ ,]+[A-Z\d]{6})*$"
Local $sString = "KEPM39, JEMGH5, HEPM21" & @CRLF & _
"KEPM39 JEMGH5 HEPM21" & @CRLF & _
"KEPM39,JEMGH5,HEPM21"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")